Carplay no longer works or recognized by the Infotainment system

Discussion in 'Clarity' started by Sam Johnson, Sep 21, 2018.

To remove this ad click here.

  1. Sam Johnson

    Sam Johnson New Member

    So my Apple Carplay in my Clarity stopped working entirely...I have an iPhone 8 Plus...also changed out the cable 5 times with no luck. If I Plug in the cable, and change Audio source cto iPod works...reset my phone and plugged in a new phone...reset the Infotainment system to default...still no carplay response everything else works. Smartphone connection button on the home menu is greeted out and says “when safe, please confirm that your smartphone is connected to the USB port which had a smartphone icon on the lid”. Yes it is connected to the correct port. The port charges the device also. Not sure what else I can try. Has anyone else experienced this issue?

    Sent from my iPhone using Inside EVs
  2. To remove this ad click here.

  3. RickSE

    RickSE Active Member

    I haven’t seen this problem but you might just want to try deleting the car from CarPlay on your phone and just setting it up again as a new connection.
  4. Sam Johnson

    Sam Johnson New Member

    Did that also:) no luck. Resetting the Infotainment deletes all devices and tried adding back. The carplay feature seems shot.

    Sent from my iPhone using Inside EVs
  5. ClarityDoc

    ClarityDoc Active Member

    I would try a different phone before making that conclusion.

    Sent using Inside EVs mobile app
  6. zbartrout

    zbartrout New Member

    I have occasional random issues with Carplay and sometimes think it’s broken. Sometimes toggling CarPlay on and off in the iPhone settings helps. I also find that it sometimes forces me to force an unlock with passcode in order to recognize. Definitely flakier than I would hope. Hoping iOS 12 with new CarPlay will improve reliability b

    Sent from my iPhone using Inside EVs
    Sam Johnson likes this.
  7. To remove this ad click here.

  8. Sam Johnson

    Sam Johnson New Member

    Tried that too...Here is the weird thing...I tried 4 different Apple iPhones...and none of them triggers the Apple Carplay...but I plugin a Samsung S9 and the bloody Android Auto it’s got something to do Apple devices/Carplay:)

    Sent from my iPhone using Inside EVs
  9. ClarityDoc

    ClarityDoc Active Member

    Gosh, Apple wouldn't engage in planned obsolescence, would it? Nah!

    Sent using Inside EVs mobile app
  10. su_A_ve

    su_A_ve Active Member

    You will be asked to:

    * Try a different OEM cable
    * Upgrade your phone
    * Try a different phone
    * Factory reset the phone
    * Factory reset the head unit
  11. su_A_ve

    su_A_ve Active Member

    iOS 12 is out and so is Google Maps. Waze is coming out soon...
  12. To remove this ad click here.

  13. Teamchang

    Teamchang Member

    Exact same thing happened to me too! Ugh.
  14. Teamchang

    Teamchang Member

  15. Teamchang

    Teamchang Member

    Ok now it works for some reason. I’m at a loss for an explanation.
  16. Sam Johnson

    Sam Johnson New Member

    Does anyone know how to factory reset the head unit on the Clarity?

    Sent from my iPhone using Inside EVs
  17. Teamchang

    Teamchang Member

    I believe you press and hold the audio “button”.
  18. PHEV Newbie

    PHEV Newbie Well-Known Member

    When I first bought the Clarity, my iPhone connected right up when I plugged it in. I did have intermittent problems that was solved by replacing a cheap cable bought from Amazon (some no name brand from China). After a iOS update, it didn't seem to connect at all. This was solved by making sure the phone is separately activated using the fingerprint ID. It's an extra step compared to before but it connects 100% of the time now.
  19. Sam Johnson

    Sam Johnson New Member

    Tried that and it only does a simple reboot IMG_5370.JPG

    Sent from my iPhone using Inside EVs
  20. Tolimaz

    Tolimaz New Member

    Same issue here with Android Auto and my google pixel. It worked perfectly from the very beginning but this week it suddenly stopped working for no reason ! If I find a fix, I'll let you know :-(
  21. Steven L

    Steven L New Member

    Waze our today. Just update the waze app on iPhone and it will be in Apple CarPlay.

    Sent from my iPhone using Inside EVs
    Pegsie likes this.
  22. GeneInOhio

    GeneInOhio New Member

    Recently I've been having issues with Carplay as well. I took a stab at cleaning the lightning jack on the phone with a stiff brush and canned air and things seem to be working better. There definitely was some pocket fuzz in the receptacle. Something to check out.
  23. Tolimaz

    Tolimaz New Member

    After 30 minutes of messing around in the phone setting and infotainment settings... I found a setting in the infotainment where my phone was disabled (but was still working on Bluetooth). I just had to re-enable it and problem solved :-S It's weird that it got disabled by itself !!!

Share This Page