USB Port Stopped Functioning?

Discussion in 'Clarity' started by MikeB, Nov 1, 2018.

To remove this ad click here.

  1. MikeB

    MikeB Member

    I had been using CarPlay quite often and just started using Waze via CarPlay when that became possible recently. As of a couple days ago, however, the USB port seems to have stopped recognizing my iphone or any other device. I've plugged in several devices using several different cables (including the ones that used to work just fine) but Mr. Clarity insists there is no device plugged in (the devices do charge when plugged into the USB port, but apparently no data transfer). I'm thinking the USB port (or something electronic in the car) is toast, but does anyone have any other ideas?
  2. To remove this ad click here.

  3. jdonalds

    jdonalds Well-Known Member

    I would check for a fuse.
  4. petteyg359

    petteyg359 Well-Known Member

    In my car, the USB ports wiggle around annoyingly when I plug or unplug anything, so I suspect the soldering job is crap. I usually just leave a cable always plugged into the port so I'm not risking breaking it more. If the port moves around, take it to the dealer and complain. If devices aren't connecting, you've got reason to make them fix it. I haven't complained about mine yet only because it's still working.
  5. JCEV

    JCEV Active Member

    Might be a software glitch. Try removing all paired devices, I think there is a menu option for apple carplay Devices. Then plug in and set up again .
  6. Alantn

    Alantn Member

    This happened to me quite often. Just reset by press and hold on the audio key at the upper left corner and when the message asks to reboot, accept. After reboot, everything should work again.
    vicw, MikeB and ClarityDoc like this.
  7. To remove this ad click here.

  8. MikeB

    MikeB Member

    Thanks Everybody! Alantn's reboot did the trick for me.
  9. Kathy

    Kathy New Member

    Are you rebooting the phone or the head unit? I'm having this problem also, and so far a phone reboot hasn't solved the problem.
  10. Sandroad

    Sandroad Well-Known Member

    Head unit. That reboot fixed our odd message about lack of connection.
  11. lessismore

    lessismore Member

    could it be failing USB cable? I have that happen a lot with lightening cables. I can see it being a problem if you have to always reboot your phone - you could be driving when it happens. would suggest that you give another cable a try to rule out this possibility
  12. To remove this ad click here.

  13. DVoran

    DVoran Member

    In my case it happens more often than not if the phone is in the locked position. If I have it on (unlocked) when connecting to the USB/Lightning connector it usually works. Happens maybe once every 6-7 times getting into the car.

    Sent from my iPad using Inside EVs
    ClarityDoc likes this.
  14. ozy

    ozy Active Member

    I went through a frustrating session of the car's head unit not recognizing android auto. Could not figure out what the problem was. Received some error messages such as "not recognizing device" and another error message indicating some kind of charging cord problem etc. I tried everything including changing the cords, reinstalling auto android, restarting phone, rebooting head unit, trying a different usb port etc. Finally I went into the settings menu and realized that for some reason my phone was not being recognized as having android auto (I saw options to select android auto or carplay). I found this strange because I had been using android auto for quite a while, but apparently it had re-set without reason. Anyway, if this happens to anyone else this is a quick and easy thing to try.
    KentuckyKen likes this.
  15. JulianClarity

    JulianClarity Active Member

    It still charges, most likely it is some pin damage. Power supply runs between Vbus and ground pins, don't worry about that. Just go to a Honda dealer and have the USB port replaced for you.
  16. coutinpe

    coutinpe Active Member

    I always have to unlock my iphone before starting Apple CarPlay. Otherwise it won't recognize it.
  17. JulianClarity

    JulianClarity Active Member

    Strange, I don't need to.
  18. rodeknyt

    rodeknyt Active Member

    I think that's normal behavior. Most likely a privacy/security feature in case someone gets ahold of your phone they can't plug it into their car and get into it. It will continue playing whatever music was in progress when it was last plugged in, but no screen icons or app access until the phone is unlocked.
  19. coutinpe

    coutinpe Active Member

    Just found out I have to turn on "allow USB accessories" under the Touch ID and passcode settings (the last option) to make it work.

Share This Page