Trick to Starting Your Kona

Discussion in 'Hyundai Kona Electric' started by Sarah Newton, Dec 30, 2019.

  1. Sarah Newton

    Sarah Newton New Member

    Sometimes our Kona starts charging fine, but other times it won't charge at all, the ring around the charging port starts flashing red and there is no charging.

    We have spent a few hours reading the manual, looked at trouble shooting web-forums, and trying other charging stations in town. Nothing worked, even though there are a myriad of suggestions online. On our own we figured out how to do it:

    If it won't charge in the usual manner

    1. Disconnect the cable
    2. Shut the charging port door
    3. Get in the car
    4. Turn the car on, in park
    5. Leave it 'running' or on, and have the doors unlocked
    6. Get out of the car
    7. Open the charging port door
    8. Hook up the charging cable, it will start charging
    9. Once charging, we then turn the car off and lock it up. It continues charging.
     
  2. The flashing red ring implies a fault. Try a different EVSE if you can. If your EVSE is not throwing any fault codes it may be a problem with the charge port connection or even the on board charger. Presumably if it was the on board charger you would see a fault code light up on your dash. Anyways you probably should have your dealer investigate. Charging process should not be that involved. I simply get out of the car plug it in and it starts charging.
     
  3. Etienne Savard

    Etienne Savard New Member

    If it was that simple, I would be happy!

    I have a red flashing port problem when at DC fast chargers. I had my car checked at the dealer last Friday, and they didn't fix the problem. A service ticket is already opened at Hyundai Canada apparently, I'm not the only one with that problem: somehow the locking mechanism get stuck when outside temperature is below freezing point (0° C or less).

    I tried to spray the lock with WD40, without any luck. The only thing that seems to resolve the problem temporary is to bring my car in an heated garage or parking...

    I just tried something else earlier today that seems to have melt what was blocking the lock: I shooted some methyl alcohol through the drainage hole just below the lock (the white pin at the very top of the connector). I will use again a DC fast charger tomorrow, hope the problem is gone.
     
  4. It definitely sounds like a problem with the charge port mechanical switch which may cause a more serious issue if the car accepts a charge without first shutting off as indicated H-21 manual.
    I am however surprised that this has not been an issue reported in more northerly locations like Norway etc. (at least to my knowledge).
    Perhaps the viscosity of the grease that lubes the travel might have to be improved (if any was installed from manufacture).
     
    Paul DeLeon likes this.
  5. Yes, and for that reason the mechanism may be intended to operate dry. The front charge port may be convenient but it seems to have caused a heap of unintended side effects, not helped by the cost-cutting design engineering.

    As for charge errors I've never had one (which wasn't my own fault) that was not corrected on the second try.
     
  6. Etienne Savard

    Etienne Savard New Member

    I think the car is doing her job by informing the fast charging station that she's not ready to receive high DC voltage. The level 2 handshaking protocol seems simpler has it allows to start recharging without the lock in place. If the level 2 charging wasn't working, I would be in trouble... That issue is just bugging me when I have to make trip outside the range of the winter autonomy of my car and don't want / can't spend hours to wait after it to charge.

    I gave my dealer a phone call yesterday, still no new information from Hyundai head office in Toronto. I will have to call them next week for a follow up.
     
  7. My Type 2 connection won't start AC charging unless the lock engages. That has happened when I tried a charging with a damaged tethered cable on a public charger. The lock hole in the plug had a burr on it preventing the bolt from engaging.
     

Share This Page