ID 4 Home Charging problems

Discussion in 'ID.4' started by Rick DiBello, Jun 27, 2021.

To remove this ad click here.

  1. Rick DiBello

    Rick DiBello New Member

    I took delivery of our ID 4 First Edition last weekend and so far love the car. But I'm having some problems with home charging. We have a Bosch Level II Charger that we installed in 2013 and has worked very well with 2 Chevy Volts and a Honda Clarity. It's not working well with the ID 4, however. I programmed it to charge overnight to 80%, and most nights it charges but never gets to 80%. Some nights it doesn't charge at all. When I use the Car-Net app to charge manually, it rarely starts. It might work 1 out of 20 times, and when it does, it stops charging premarturely.

    My questions are:

    1. Has anyone else had similar problems? If so, were you able to fix them, and how did you do it.

    2. Is it possible that my old Bosch wall unit isn't compatible with the ID 4? Should I replace it?

    Thanks in advance for any insights you can provide.
    Domenick likes this.
  2. To remove this ad click here.

  3. ericy

    ericy Well-Known Member

    Scheduled charging or time of use preferences do not work well in the car - common problem. Hopefully fixed in the next update.

    If you just plug the thing in with no preference or schedule, it should charge without a problem.
    rcarter3636 likes this.
  4. Rick DiBello

    Rick DiBello New Member

    Kinda figured. That's what I've been doing. Can't believe how crappy the current software is! Definitely not ready for prime time!
  5. Mowcowbell

    Mowcowbell Well-Known Member

    Have you tried a different evse? Wondering if maybe the contacts in the Bosch are getting worn? Is the Bosch mounted inside or outside?
  6. Rick DiBello

    Rick DiBello New Member

    The Bosch works perfectly when I'm not using the Car-Net app to program the charging time. And it sorta works with the app, but never charges to my 80% target; it always stops short. Sometimes it doesn't charge at all. Once I abandoned the app and started charging manually, everything worked fine. So, I doubt the Bosch is the problem. Seems like a VW software problem to me, but I'm really not sure.
    SkyShotEV likes this.
  7. To remove this ad click here.

  8. SkyShotEV

    SkyShotEV Member

    Has this improved or resolved?
  9. ericy

    ericy Well-Known Member

    We don't know. The OTA software patch was just released a day or so ago to a limited audience in Europe. A few people have received it (two in some German forums), but I have not yet seen anyone test to see if the bug was fixed or not.

    The car only checks for an OTA once a week, so it might be a few days before a prominent youtuber gets it and has a chance to do exhaustive testing.
  10. SkyShotEV

    SkyShotEV Member

    Makes sense. Ok
  11. Ben Feldman

    Ben Feldman New Member

    I have a Bosch Level II charger I installed in 2014 and it has worked perfectly for two seperate Nissan Leafs that I have owned. I just bought the VW ID.4 and it it s not working at all. I try and plug it in and I get a green light on the charger plug for about 30 seconds then it turns red and I get a message that reads "vehicle could not be fully charged. Please see owner's manual. Does anyone have an idea what to do?
    electriceddy likes this.
  12. To remove this ad click here.

  13. The first thing I would do is to try to eliminate any user software settings in the car that would prevent charging (such as scheduled charging etc).
    The easiest way to do this is to try a public L2 charger and see if the same situation occurs, then go from there;)
    VeeDub'r likes this.
  14. rcarter3636

    rcarter3636 Member

    Have you tried the level 1 J1772 that came with the i.D4?
    That will probably tell you if it’s your Bosch charger or your iD4.
    ericy likes this.
  15. Ben Feldman

    Ben Feldman New Member

    Yes I have plugged the car into a standard level II charger and it works fine. Any suggestions? It seems like my Bosch Charger is not compatible with ID.4?
    ericy likes this.
  16. ericy

    ericy Well-Known Member

    Is there a firmware update for the Bosch? That's the 1st thing I would look at.
    Domenick likes this.
  17. Ben Feldman

    Ben Feldman New Member

    I have checked Bosch website and internet and I do not see anything about firmware update. The charger worked perfectly fine for my leave for 6 years, it just does not seem to work for new ID.4
  18. +1 on electriceddy's recommendations.

    Does your Bosch EVSE give any external indication of it's connection or fault state?

    Do you hear the "thunk" of it's contactor closing?

    If you are electrically-savvy, and comfortable working w/ and in the vicinity of line-voltages AND have a high-impedance meter (or scope) capable of reading 1 kHZ "peak" voltages, you can possibly check the system's pilot voltage.

    The vehicle first needs to "pull-down" the peak (vice RMS) pilot voltage supplied by the AC Level-II EVSE to +9VDC to tell the EVSE that a vehicle is "connected" ...

    ... and then pull it down further to +6VDC to signal "ready to charge" (i.e. to cause the EVSE's 2-pole AC contactor to close)

    Note that these are the pilot voltages "as-sensed" AT the EVSE while it's connected to the vehicle.

    Of course if it's NOT doing this, there are additional troubleshooting steps to determine "why."

    A good high level overview of J1772 AC Level-2 charging control theory is available here:
    Last edited: Aug 11, 2021

Share This Page