CarPlay issue. Just me?

Discussion in 'Clarity' started by brentac, Feb 26, 2018.

To remove this ad click here.

  1. brentac

    brentac Member

    I've had my car for a couple weeks now and I'm noticing fits of my iPhone X not staying connected to the usb for CarPlay. sometimes it'll seem solid, other times it'll drop every couple of minutes (but appears to be charging still). Anyone else having this?

    I've tried different lightning cords, and actually had apple look at/clean the lightning port on my iPhone. I'm in and out of my car all day for work. Today I've noticed that when I plug it in, if it doesn't connect, unplugging and re-plugging it at the usb end (not the lightning) would connect it every time.

    my next step is obviously seeing if Honda can look at it and possibly replace the USB but figured I would find out if I'm on my own with this one.
  2. To remove this ad click here.

  3. bfd

    bfd Active Member

    I've had some similar observations. Like CarPlay won't automatically launch. I sometimes get a message to "plug in when it's safe". Other times plugging in before driving, no CarPlay shows up. Smartphone connection sometimes kicks it into gear. And yes, I've also disconnected and reconnected the usb end of the cord. Seems like it's kind of a flaky connection to me. However, I haven't had it just drop out as was mentioned.
  4. Pogue

    Pogue New Member

    Yes, I had those same dropouts! I bought a new, Apple-branded Lightning cable just for that purpose, and so far (this was 3 days ago), no more dropouts...but maybe that's just me!
  5. cowgomoo

    cowgomoo New Member

    Me too! I thought it was the cable and replaced it. Then I thought it could be pocket lint compressed inside the lightning port - cleaned it, now I think it has to be the socket in the car.

    Sent from my iPhone using Inside EVs
  6. erwheezy

    erwheezy New Member

    Just started having issues with carplay, tried replacing the cable and its still dropping connection. Anyone else having issues with sat radio? Two days in a row with no sound and unresponsive. Rebooting the unit fixes the issue but it is annoying.
  7. To remove this ad click here.

  8. brentac

    brentac Member

    how do you reboot the unit? outside of restarting the car?
  9. dstrauss

    dstrauss Well-Known Member

    Press and hold the audio power button in top left corner of screen until it reboots.
  10. cowgomoo

    cowgomoo New Member

    If you precondition the car the SiriusXM radio wont work until you reboot or restart. The work around is to change your audio source to something else before turning the car off for the night if you plan on preconditioning in the morning.

    Sent from my iPhone using Inside EVs
  11. brentac

    brentac Member

    dstrauss that makes so much sense I'm ashamed I didn't think to try it.
  12. To remove this ad click here.

  13. HappyValley

    HappyValley New Member

    Thanks for the information! This happened to me this morning and I was perplexed!

    Carplay for me so far has been a challenge when playing my downloaded audio from SiriusXM. Most of the time, it works, but other times I select the download and I get a wheel that spins and the show never plays. If I have something playing on my phone while walking to the car, once connected, it automatically starts playing, which is really nice. With that said, I love the functionality of Apple Carplay and the ability to use Apple Maps so that's my strong preference. I suppose if I was patient and got everything setup before pulling out of the garage, I wouldn't be so frustrated! I usually plug my phone in when I enter the vehicle.
  14. brentac

    brentac Member

    For what it's worth, and keep in mind small sample size, on Saturday evening I wiped my phone and restored from an iCloud back up. (no it's not as big of a deal as it sounds, pretty simple compared to what it used to be.)

    Since then CarPlay has been rock solid. so that might be an option if you too are having issues with it.
  15. bfd

    bfd Active Member

    It's non-trivial unless you have any cards in Apple Pay. If that's the case, you will have to re-enter all of them, and for me, anyway, that can be a pain if any of the banks requires a phone-in authorization. At that point, it's easier to just carry the card. Double trouble if you have the cards on your Apple Watch as well. First world problems. Just beware of possible added distractions if you nuke and repave your iPhone…
  16. brentac

    brentac Member

    you only have to re add them from scratch if you start your phone over. wiping it and restoring an iCloud backup gives you many of the same advantages like putting the OS back to a default state. If you do that all you have to do for your Apple Pay cards (that don't require phone) is put in the cvv code or whatever it's called on the back. If you do have to do the phone then, yes, that would be annoying. You don't have to re add them all to your watch because you can select the option to add them to the watch at the same time.

    the nuke and pave is different. that applies to setting up an iPhone as though a backup doesn't exists, and yes, that is more time consuming and annoying as you are seemingly forever remembering an app you want or a setting you hadn't changed.

    all told its been completely worth it. CarPlay has yet to disconnect.
  17. AGarg

    AGarg New Member

    Hello all. Love the Clarity but struggling with Apple CarPlay. Based on the above recommendation, I rebooted the central console by pressing and holding the audio power button but Apple CarPlay didn't work. Error message 'No Apple CarPlay device is connected'. Tried 2-3 different cords (all Apple original) connected to the USB port which has a smartphone icon in the lid but no luck. Any suggestions? Is there any setting on the iPhone that I'll need to enable?
    CupertinoClarity likes this.
  18. AGarg

    AGarg New Member

    So the issue was with the iPhone setting. I disabled Restrictions on the iPhone by going to Settings --> General --> Restrictions and Apple CarPlay is working fine now. Yay!
    loomis2 likes this.
  19. bfd

    bfd Active Member

    I've always had restrictions disabled, and CarPlay is still a crapshoot for me, particularly if I don't start IT before I start driving the car. So I do think there's something to engaging the CarPlay system before engaging the wheels. However, more than once, this has not been the case and I get the "plug in when it's safe" message. Some fixes have worked (like rebooting, removing and reinserting the usb connection), but not always. I am glad for the $5/month for a year SiriusXM I have. When CarPlay is a non starter, it's a big help.
  20. CupertinoClarity

    CupertinoClarity New Member

    Wow thanks! Eltropy?

Share This Page