Car doesn't recognize phone anymore for Android Auto

Discussion in 'Clarity' started by Cay, Jun 6, 2020.

To remove this ad click here.

  1. Cay

    Cay New Member

    I saw some other issues with Android Auto, but not this one specifically.

    Back in February, I was driving home from the dealer where I had the car serviced (I think this was a coincidence as I do not believe any updates were done) and I had my phone plugged in and was listening to a podcast via Android Auto. Suddenly the screen and the sound froze. I unplugged and replugged the phone several times and then rebooted the phone. The screen finally went back to the default, but it wouldn't recognize the phone at all (Galaxy S10).

    I deleted all the phone profiles and started over. I was able to pair the phone via BT, but it would not recognize it plugged in. I tried several different cables (no go) and an older Android phone (worked immediately). I didn't talk to Honda because the old phone worked fine so I assumed that it wasn't a car issue.

    Interestingly, the Android Auto app disappeared from my phone at the same time so it couldn't be uninstalled or altered, but also couldn't be installed because the phone said it was already installed. Called Verizon, they tried troubleshooting. No go. They sent me to Samsung, who said it was clearly a software problem. A factory restore didn't fix things.

    Samsung sent me to Google. Google told me it was a hardware problem, not an Android problem. After two weeks of phone calls and frustration I ended up back to Verizon who replaced the phone under warranty. The new phone worked immediately and fine...until last week.

    Same situation - I was driving (not from dealership!) and Android Auto crashed and wouldn't come back up and the car won't recognize my phone other than through BT since then.

    It seems to be unlikely to be a car issue because my old phone and the new phone worked perfectly. Yet Verizon, Samsung, and Google couldn't pinpoint an issue with the my phone in February and now it seems to be happening all over again (I haven't started troubleshooting other than waiting a few days and then trying again today). But I had no issues with either phone until this issue and it's weird for it to be happening with two different phones unless it's a pretty significant software bug.

    Thoughts? This is very frustrating as I use Android Auto extensively in the car and my driving experience is decreased without it.
  2. To remove this ad click here.

  3. Teslawannabe

    Teslawannabe Active Member

  4. Mowcowbell

    Mowcowbell Well-Known Member

    Have you restarted the infotainment unit in your Clarity? If that doesn't work, then try disconnecting the negative cable to the 12v battery. You'll get a lot of warning lights for the first drive or two, but that will definitely reset things and clear system memory.
  5. Teslawannabe

    Teslawannabe Active Member

    Not sure if this is what you are experidencing but this is what happned to me. When my Note 9 updated to ver 10 I did an uninstall because of android issues. Then I tried to re install and it said it was already it was already installed. Researching this I found android auto became part of the operating system however I had no icon to select to run from the phone. Turns out android auto had to issue a new app for the phone screen to run android auto directly from the phone. This app is called Android Auto for phone screen. This will allow you to run from your phone. Hope this helps.
  6. Sthomasa

    Sthomasa Member

    i have an S20. THE AA "ignore" happened to me. Realized I had "wireless" android auto checked on phone. Clarity doesnt support that. Reboot all, works now.
  7. To remove this ad click here.

  8. Cay

    Cay New Member

    Haven't tried this - sounds a bit daunting! But do you think this would solve the issue if my old phone still works?
  9. Cay

    Cay New Member

    I'll check this. Weird that it would happen in the middle of using it if that was the case.
  10. Cay

    Cay New Member

    Yes, this makes sense based on what I'm seeing. The weird thing is that Verizon, Samsung AND Google seemed unaware of this! Also strange that a factory restore didn't fix it on the first phone, but starting over with a new phone did...for a couple of months.

    I'm aware of the Android Auto for Phone Screen app, but it's really important to me to get AA displayed on the car's screen.
  11. Cay

    Cay New Member

    Update: I got it working. Here's what I did:
    1. Uninstalled all updates to Android Auto
    2. Went into Developer Mode on phone and enabled USB debugging
    3. Rebooted infotainment system
    4. Deleted all phones connected to car

    I tried the phone after the first two steps and it still wasn't working. Then I did steps 3 and 4. It seemed like deleting all the phones was what really fixed it, but I tried this a few times previously and it didn't work, so perhaps one of the other steps was also needed?

    Fingers crossed that it stays fixed this time or at least responds to the same steps if it doesn't...
    Last edited: Jun 14, 2020
    JJim and Mowcowbell like this.
  12. To remove this ad click here.

  13. glockgirl

    glockgirl Member

    the change in the app setting did the trick for me. on my pixel 4 it was set up for wireless, once i un-check that box, everything worked. i even tried a bunch of different cables, no issues. i have had my car for over 18m and never much cared for it, but i figure i'll give it a try now. if i end up using it a lot, i might look in to getting a wireless adpt for it. but that's a few month down the line.

Share This Page