Apple Carplay won't connect to my phone

Discussion in 'Clarity' started by KClark, Oct 11, 2019.

  1. KClark

    KClark Active Member

    I don't use carplay very often, most of my driving is a well worn commute that requires nothing more than NPR on the radio. Today a major brush fire here in LA has closed some of the freeways on my drive and traffic was snarled. No problem, I'll just connect my phone and check out Google Maps to get me to work. To my surprise it wouldn't connect, surprised because I have used Carplay before without problems in my Clarity.

    When I connect the phone to the USB cord the Carplay splash screen shows on the phone so it appears to be connected to the car and the charging icon shows on the battery icon so there is also power going through the cable. I go to smartphone settings on the dashboard screen and choose Carplay. It shows iPhone on the list of devices. I click on it and it asks me do I want to enable, disconnect or delete the device. I click on enable and it says "This device will enable when it is reconnected to the USB port." Strange, because I know it is connected, but I unplug the phone and replug. Nothing happens I still see the iPhone on the list of devices and again get the same message that it will enable when reconnected to USB when I click on Enable. I've also tried unplugging the cable from the car USB as well as restarting the car but nothing changes, I get all of the same indications and the same message. Even though there is power, a connection and the phone shows Carplay I can't get it to start working.

    I recently upgraded to iOS 13, anyone else having problems with this since upgrading? Any other help or suggestions?
     
    Last edited: Oct 11, 2019
  2. SThomas219

    SThomas219 Member

    I am still on iOS 12 due to a couple of apps I use that have issues with 13.

    However, I often experience issues connecting Carplay to the Clarity (and other cars with Carplay). First, try rebooting the entertainment system by pressing and holding the Audio icon on the top left of the screen. Do this without the phone plugged into the USB Port. Once the system comes back up fully, plug the phone back in. This often fixes the issue.

    If it doesn't, reboot the phone itself before plugging back in. Carplay is not as seamless as it should be. I have issues with Ford's Sync 3 system as well.
     
  3. Groves Cooke

    Groves Cooke Active Member

    I am sorry I cannot help you, but here are my thoughts about Carplay. About 4 or 5 years ago I thought that using a phone's navigation on the center screen would be a great idea. I was excited when car companies started doing this. I looked forward to using it on my Clarity. Fortunately I have the touring version which of course has its own navigation. I very rarely use Carplay because I find the built in nav program to be much easier to use. Everytime there is an upgrade to the phone's OS there are changes to Carplay which require my attention - attention that I don't want to give. I don't know how Carplay works with different car makes, but it is a disappointment as currently configured in my Clarity. There are workarounds. Just use the phone itself and don't use Carplay.
     
  4. DucRider

    DucRider Active Member

    Try a different cable. I've had weird results from flaky USB cables.
     
    fotomoto and delrey like this.
  5. delrey

    delrey New Member

    Agreed, seems that some cables will charge but be flakey for Carplay.
     
  6. 4sallypat

    4sallypat Active Member

    I use genuine Apple Lightning cables and never had an issue.
    Currently using: XR and 11 iPhones with current iOS 13 and no issues....
     
  7. KClark

    KClark Active Member

    Yes, just using the phone without CarPlay is an option but I like having the big screen and the easy visibility with CarPlay. And like I said, I’ve used it in the past and found it very useful and well done. This is a genuine Apple lightning cable but I have seen cable problems with electronics in the past so it’s a possibility, although it is an iPhone 7, is the ghost of Steve Jobs reaching out to tell me it’s time for an upgrade?

    But before I tried new hardware I first tried SThomas’ advice. I rebooted the infotainment unit, the first time I’ve done that in 10 months of ownership. No change. Then I tried restarting the phone. No change. But after restarting I noticed there was an iOS update so I installed 13.1.2. And CarPlay now works again.

    Thanks for the replies and suggestions.
     
    Last edited: Oct 11, 2019
    fotomoto and Sandroad like this.
  8. Tom H

    Tom H New Member

    I just had my 2018 Clarity Plug-in forget how to do CarPlay with my phone (nothing I know of changed). After trying all the normal things to get it to work with no success, I got it to work by rebooting the entertainment system by pushing the Audio button until it asked if I wanted to reboot. Answered yes and after a while it was rebooted and asked if I wanted to enable CarPlay. After answering yes to this everything was good again.
     
  9. coutinpe

    coutinpe Member

    Good it finally worked for you. I also have an iPhone 7 and never had any issues with CarPlay after I stopped using cheap cables and switched to the genuine one coming with the phone. The SJ ghost wasn't involved :)
     

Share This Page