Android 10 and HondaLink

Discussion in 'Clarity' started by Mowcowbell, Sep 5, 2019.

  1. Mowcowbell

    Mowcowbell Active Member

    If anyone is concerned about Android 10 breaking HondaLink... well don't worry. I upgraded my Google Pixel XL phone to Android 10 and it runs HondaLink just fine. You will need to log back in with your credentials the first time after the upgrade.
     
    Clarity_Newbie likes this.
  2. Joe Freeman

    Joe Freeman New Member

    M- glad you had a good experience but mine is totally different - with the new update it's impossible to log in unless you change your phone to using the new gesture mode as the login button lies under the home button on the screen - it's impossible to select the log in link without getting sent back to the home screen. App won't rotate to landscape view so that won't work either. Only way to get to the log in screen is to choose the demo option and then hit the menu on succeeding screens - really annoying. Even then I couldn't get it to show my vehicle (2018 Touring) - vehicle is greyed out and the app does not list the Clarity as a compatible model!!

    So - see ya Honda Link - never really used it much anyway, life is too short to deal with it ....
     
    JustAnotherPoorDriver likes this.
  3. JustAnotherPoorDriver

    JustAnotherPoorDriver Active Member

    Came here to post about the same problem. Can't relog in.

    No idea how to do the demo->menu trick. Haven't been able to figure that out...
     
  4. Mowcowbell

    Mowcowbell Active Member

    1. First, tap on the Android 10 Settings logo.
    2. Then, scroll down through the menu options until you reach, and tap on, System.
    3. Then, tap on the Gestures selection in the menu
    4. Then go down and tap on the System Navigation option.
    [​IMG]

    1. You should then see three options; the older 3-button navigation selection at the bottom, the more recent 2-button navigation in the middle and the new Gesture Navigation on top. (You can see examples of what each of these selections look like in the images above). Tap on the Gesture Navigation selection to enable that particular option.
    2. If you decide that gesture controls are not for you, you can repeat the same steps above and then tap on either the 3-button or 2-button navigation selections.
     
  5. JustAnotherPoorDriver

    JustAnotherPoorDriver Active Member

    I know how to switch to gestures (and did to fix this), but Joe mentioned some other demo->menu trick
     
    Mowcowbell likes this.
  6. Kerbe

    Kerbe Member

    My Pixel 3 upgraded at midnight on September 3 so, the next morning, I went through and logged into all the apps that had disconnected. Honda Link won't connect to the Clarity - I wonder if I need to re-initiate the connection from from the car side...
     
  7. Kerbe

    Kerbe Member

    I uninstalled Honda Link from my phone, rebooted and then reinstalled. First thing this morning it seemed to be working, only it said my car was plugged in, which it wasn't, and didn't list anything for SOC or available mileage. Then it couldn't find the car, which I was standing next to at the time... So it looks as if the app is toast at the moment.
     
  8. insightman

    insightman Well-Known Member

    Based on HondaLink history, I expect we people with Android 8 (and 9?) will soon learn that our phones are no longer supported.
     
  9. 2002

    2002 Well-Known Member

    Same here on my Android 9 phone, the problem started on Friday at least that's when I first noticed it. If I try and modify the charging schedule I get an error "Failed to update schedule. Please try again later." The past two nights I had to use the car settings menu to schedule charging, first time I have ever had to do it that way because the app has always worked for scheduling charging since I got the car in April. I also tried uninstalling and reinstalling the app and that doesn't help. People in the past have reported the app stops working then a day or two later it starts working again, I hope that is the case for us also.

    Interesting like yours the app is stuck on "charging" i.e. showing that the car is charging when it is not. So for both of us the cell phone connection was apparently lost while the car was charging and it has not been able to connect since then. The bluetooth connection for phone calling etc. however still works. The SOC shows 13% which would be the SOC at the beginning of charging so that means in my case cell phone connection was lost not long after charging started probably Thursday night if I remember correctly.
     
  10. vicw

    vicw Active Member Subscriber

    I've been using Hondalink on the Android 10 betas with no problems for the last few months. Since I updated to the release Android 10 on 9/3, I'm still able to log in to the app with no problem, but the last time it showed an updated status was yesterday (Fri, 9/6@12:30 PM EDT), and the status it reported was actually obsolete.

    I'm not getting any more reported updates from it. The scheduled charging activity worked properly last night, but Hondalink didn't show that activity while it was charging, and said that it had failed. If I try to find the car on the app, it just times out, or reports that it is unreachable, and that the car may be in a low signal area, while parked in locations that have worked previously.

    There haven't been any app updates since June, so it doesn't seem to be a new bug in the app. I really doubt that the Android 10 update is the source of the problem. I suspect, and I'm hoping (praying?) that Honda has a problem on the server end, and that they can fix it soon.
     
  11. RickSE

    RickSE Active Member

    I have an iPhone and my HondaLink hasn’t connected since Thursday night. It doesn’t even update when plugged into the car. I suspect something on the server side at Honda is down.
     
    Elm and Olive like this.
  12. Mowcowbell

    Mowcowbell Active Member

    Just tested all menus in HondaLink and everything is working. It correctly shows my car in my garage when I click on find my vehicle. Was able to set/change charging times, and when charging it properly shows that status in the app. Don't think it's a server end issue at this point.
     
  13. vicw

    vicw Active Member Subscriber

    I don't doubt your results. Happy to know that it is working for you. I think it's possible that a server end problem might just affect certain individual accounts, though. I just tested via my old Nexus 7 tablet on Android 6.0.1, and had the same problems as on Andoid 10 currently on two different phones, and that RickSE is having on his iPhone.
     
  14. Olive

    Olive New Member

    I got my 2019 Clarity in july. Hondalink "almost" worked flawlessly since then. I'm on IOS with iPhone 8. But suddenly, saturday morning (yesterday), it stopped working. I always get the message that it can't communicate with the car or that the car is in a place without cell coverage. My car is always parked outside and the cell tower is a few hundred feets from my house.

    I would think that the problem is on the Honda server side...
     
  15. KentuckyKen

    KentuckyKen Well-Known Member

    I’m on an iPhone 7 w IOS 12.4.1 that has worked flawlessly until this weekend. I haven't gotten any updates since Thursday at 8 pm.
    Looks like a Honda server problem.
     
    insightman, Daniel M W and Elm like this.
  16. Mowcowbell

    Mowcowbell Active Member

    I forgot to mention on my earlier post that I did uninstall/reinstall the Hondalink app after I finished the Android 10 update. Perhaps there is something stuck in local cache that is causing the issues for some of you guys?
     
  17. vicw

    vicw Active Member Subscriber

    I wondered about that too, but I don't think so. I made new installs of the app on a second phone, after the Android 10 update, and my tablet, using the older Android OS, with the same results on both. Also, some iPhone users are reporting the same apparent problem on their phones starting the last few days.

    FWIW - I uninstalled the Hondalink app on all three devices, then reinstalled it on my primary phone (Pixel 2XL). Sadly, no improvement, still no updates from the car. (I did note that when installing Hondalink on Android 10, the app sign-in button was directly on top of the Home button, so I did have to temporarily set the phone to Gesture Navigation, to allow me to select the Sign-in to proceed with the app.)
     
    Last edited: Sep 8, 2019
    Mowcowbell likes this.
  18. Danks

    Danks Member

    I'm on Android 8 and my HondaLink quit updating the EV and HV Range and the Location since 4:41 am Thursday. It has updated the Odometer twice since then. I did a force stop and restarted - nothing. I uninstalled and reinstalled - nothing.
     
  19. Robert_Alabama

    Robert_Alabama Active Member

    Mine also went out at sometime after 8:46PM Central on Thursday night as did a coworker who also has a Clarity. No updates for me since. Trying to use it to find the car just gives a message "Unable to retrieve vehicle status. Vehicle may be in an area of low reception". By the way, I also have an iPhone 7 which has always worked just fine...
     
    Elm and Olive like this.
  20. Danks

    Danks Member

    Mine gives the location the car was in at 4:41 am Thursday - at home. I checked it today when I was out and had it plugged into a charger. Didn't register that it was plugged in, or charging, and still said it was at home.
     
    Elm likes this.

Share This Page