Android Auto

Discussion in 'Hyundai Kona Electric' started by Wildeyed, Feb 7, 2020.

  1. I'm not sure how AA actually works, whether it's a Kona EV issue or a phone/app issue. So I thought i'd enquire of the group brain.
    My AA just stopped working. When I plug in my phone now AA does not come up, on the phone or car screen. It used to and generally worked okay, if occasionally a bit twitchy. Anyway, my phone is a Google Pixel 3xl and the AA app is installed and automatically updated. So can the car cause this or is it a phone/app issue?
     
  2. In my experience so far I'd say it's the phone.
    I had a lot of problems with my old phone which was doing just perfect otherwise.

    Got a new phone and AA is working just fine now.

    So I would try to actually uninstall AA and reinstall. Make sure to clear cache etc. Before you uninstall so all the data associated with it is gone and it's a fresh as it gets install.
     
  3. Thanks. Because I have a Google phone I can't uninstall Android Auto. It's built into the phone. I did force an update. No change.
     
  4. SkookumPete

    SkookumPete Well-Known Member

    You should be able to clear the app cache and data, in system settings -> apps. I don't say this will solve the problem, but at least it gives you a fresh start.

    Presumably you have tried running AA on the phone before plugging in.

    Is it possible you've accidentally disabled AA in the car's settings?
     
  5. VideoSteve

    VideoSteve New Member

    My issues connecting CarPlay to my Bolt have always been the cable. I’m on my fourth one. The non-apple versions have been most troublesome for me.


    Sent from my iPad using Inside EVs
     
  6. As mentioned, try to clear the app cache and data in settings. You can also try to uninstall all updates, which should still be possible. Even if you can't uninstall the whole app.
     
  7. I thought my issue was cables, but after buying 2 new ones directory from Google for my Pixel 2 and having them both 'fail', I discovered the problem was easily fixed by picking all the pocket lint and mung out of the USB port with the pointy end of a Tooth Banjo (best brand: Oral B Glide, any mint flavor at all).
     
    Devhead, Toolworker and SkookumPete like this.
  8. I cleared the cache and it worked today. It's twitchy so often though that I can never be sure if the fix is permanent or passing.
     
  9. Canada Dan

    Canada Dan Member

    As a couple others have said, it's likely usb related, either the cable or a clogged up usb port. I've had both problems, on the Kona and my previous car. I have a nice braided 6 inch cable with an L connector that works great now, and the phone can actually lie flat in the little cubby.
     
  10. Make sure there is plenty of space available on your phone. My experience with my old phone was that it worked a lot better when there was more space on it. Try to uninstall apps you don't use.
     
  11. IMHO, I really HATE Android Auto ... It is just so archaic and needs a serious Overhaul from the ground up. Not sure what GOOGLE engineering was thinking when they developed it. but that's another story .... :)
     
  12. Not sure sure what you find archaic about it. They just gave it an overhaul and I think it looks better than before.

    It would be great if you could have skins.

    The only thing I really don't like is that your phone always has to charge. And no, wireless Android auto is not a solution since it's not widely available.
     
  13. Is wireless Android auto supported on the Kona EV 2020 Ultimate?
     
  14. Mark_PDX

    Mark_PDX New Member

    Android Auto (AA) has been the only significant frustration with our 2020 Kona Electric Ultimate, but I don't think it's the car's problem. It works perfectly with my Pixel 3 phone, but disconnects randomly with my wife's Moto X4. Since the car and cable are the same, I conclude it must be her phone, but can't be sure if it's hardware (bad jack?), flawed AA software, or even some obscure setting (power-saving? other apps interfering?). I have cleaned her phone's USB-C jack with 100% IPA, canned air, and examined it under a microscope, but this did not fix the problem.

    This is a common problem in Google's support forum for AA, across many phones and many cars. I suspect the AA software can not tolerate even the slightest glitch in the USB data path. Until Android comes up with a wireless connection (like Apple CarPlay which uses both Bluetooth and WiFi) I doubt if it will be resolved.
     
  15. I had a Moto X4 and it worked better when I had plenty of space available. When it got full the connection got worse.

    However, I just switched to the Moto G7 and that works flawlessly so far.
     
  16. I use Android Auto almost exclusively to send and receive texts via voice control. What bugs me is how weirdly inconsistent it is. Sometimes it wants to know which particular phone I want to text, home, work or cell but other times it just defaults to one. Sometimes it says sending message, okay, message sent. Others it just says sending message. Was it sent? I don't know. And then other times it says Okay, message NOT sent. Love that one.
     
  17. Yes, but only specific (later) phones... e.g., my Galaxy 6 is NOT supported for AA wirelessly. I think it starts with like a Galaxy 8, or later.
     

Share This Page